Office : 0358554142 | WA / Phone : 0856-483-90911(isat),0822-665-99990(tsel) admin [at] bikindesainsitus.web.id

Pernah install paket di linux ubuntu kemudian muncul komentar kayak gini ;

Reading package lists… Done
Building dependency tree
Reading state information… Done
You might want to run `apt-get -f install’ to correct these:
The following packages have unmet dependencies:
epiphany-extensions: Depends: epiphany-gecko (>= 2.24) but it is not installable
E: Unmet dependencies. Try ‘apt-get -f install’ with no packages (or specify a solution).

setelah saya ketikan perintah sudo apt-get -f install di terminal muncul komentar

Reading package lists… Done
Building dependency tree
Reading state information… Done
Correcting dependencies… Done
The following packages were automatically installed and are no longer required:
squid-common liblrdf0
Use ‘apt-get autoremove’ to remove them.
The following extra packages will be installed:
epiphany-browser-data epiphany-gecko
Suggested packages:
mozplugger
Recommended packages:
epiphany-browser
The following packages will be upgraded:
epiphany-browser-data epiphany-gecko
2 upgraded, 0 newly installed, 0 to remove and 46 not upgraded.
2 not fully installed or removed.
Need to get 3600kB/4116kB of archives.
After this operation, 295kB disk space will be freed.
Do you want to continue [Y/n]?

terus apa masalahnya? Kan tinggal ketik Y, terus nanti otomatis akan mendownload paket yang dibutuhkan plus dependensi-nya. Narik napas….. ehmmmmmm…. ya kalo koneksi lanjtar dan filenya kecil, gimana kalau sudah filenya besar dan koneksi lemot kayak bekicot yang kakinya di amputasi terus pake tongkat untuk berjalan?? parah kan…??. padahal kita ingin install paket lain. Dan yang pasti paket lain tersebut tidak akan mau terinstall sebelum paket yang bermsalah di upgrade (dalam kasus ini : epiphany-gecko ), atau di buang. Padahal kalau mau buang harus upgrade dulu lewat jaringan yang sangat lemot.
Jangan kuatir… ini solusinya untuk memaksa remove (atau remove paksa) paket yang membandel dengan dependensinya. Pada terminal ketik sudo dpkg -P –force-depends epiphany-gecko (untuk epiphany-gecko silakan ganti dengan nama paket yang mau kamu buang). Kalau ada komentar kayak gini

(Reading database … 187244 files and directories currently installed.)
Removing epiphany-gecko …
Purging configuration files for epiphany-gecko …

berarti sudah berhasil.
Ada pertanyaan? Silakan tinggalkan komentar.

Komentar via Pezbux :

Pin It on Pinterest